Pin builder
Incident Report for Pinterest
Resolved
We've fully resolved the issue and Pinterest Pin builder should be working as expected. Thanks for your patience.
Posted Apr 02, 2024 - 14:03 PDT
Investigating
Pinterest Pin builder is experiencing an outage. Our engineering team is working to identify the cause and implement a solution as quickly as possible. We'll share another update shortly.
Posted Apr 02, 2024 - 13:38 PDT
This incident affected: Pins (Pin builder).