Related Pins - Outage
Incident Report for Pinterest
Resolved
We've fully resolved the issue and Pinterest Related Pins should no longer be experiencing an outage. Thanks for your patience.
Posted Mar 20, 2024 - 17:09 PDT
Monitoring
Pinterest Related Pins is experiencing an outage. We've implemented a solution to reduce the number of people affected and have partially recovered. We are monitoring for any additional problems and hope to have the issue fully resolved soon.
Posted Mar 20, 2024 - 17:04 PDT
This incident affected: Pins (Related Pins).