We've fully resolved the issue and Pinterest Ads Manager, Boards, Home, Pins, Profile, Sign up and login, The Pinterest API should no longer be experiencing a partial outage. Thanks for your patience.
Posted Jul 18, 2025 - 19:43 PDT
Investigating
Pinterest Ads Manager, Boards, Home, Pins, Profile, Sign up and login, The Pinterest API is experiencing a partial outage. Our engineering team is working to identify the cause and implement a solution as quickly as possible. We'll share another update shortly.
Posted Jul 18, 2025 - 16:33 PDT
This incident affected: Ads Manager (Ads Manager — Creation, Ads Manager — Reporting, Ads Manager — Bulk Editor, Ads Manager — General, Ads Manager — Billing, Ads Manager — Delivery, Catalogs), Sign up and login (Sign up, Business sign up, Login, Business login), Home (Home feed, Business hub, Today Tab, Search, Push notifications), Profile (Profile, Business profile), The Pinterest API (Conversions Endpoints, Campaign Management Endpoints, Audience Targeting Endpoints, Analytics Endpoints, Shopping Endpoints, Content and Core Endpoints), Pins (Pin builder, Pin save, Pin closeup, Related Pins), and Boards (Board create, Board sections).