Pin builder
Incident Report for Pinterest
Resolved
We've fully resolved the issue and Pinterest Pin builder should be working as expected. Thanks for your patience.
Posted Nov 06, 2024 - 18:54 PST
Investigating
Pinterest Pin builder is experiencing an outage. Our engineering team is working to identify the cause and implement a solution as quickly as possible. We'll share another update shortly.
Posted Nov 06, 2024 - 17:28 PST
This incident affected: Pins (Pin builder).